nowork_flutter_pubspec
nowork_flutter_pubspec
スポンサーリンク

パッケージを追加する際に最新のバージョンを指定したい

Flutterプロジェクトにおいて、pubspec.yamlでパッケージを追加する際に、最新のバージョンを確認して指定する方法

pub outdated

ヒーラー
新しくパッケージを追加するときに、最新バージョンを知っておきたい

解説

Flutterプロジェクトにて、パッケージを追加するときには、pubspec.yamlでパッケージインストールをすると思います。

何も考えずに最新バージョンをインストールするなら、とくにバージョン指定する必要はありませんが、他のパッケージとの整合性や、チームとして安定バージョンを揃える意味で、あえてバージョンを指定したい場合もあると思います。

//最新バージョンを設定する場合
dependencies:
  flutter:
    sdk: flutter
  firebase_core:
  firebase_auth:
//バージョンを指定する場合
dependencies:
  flutter:
    sdk: flutter
  firebase_core: ^0.3.0
  firebase_auth: ^0.5.20

しかしながら、新しいパッケージを追加する場合や、他サイトの情報で書かれていたバージョンに古い可能性がある場合、最新のバージョンが分かりません。

その場合、pub outdatedコマンドで最新のバージョンを確認することができます。

Android Studio上の以下画面の右上の「Pub outdated」を押せばすぐに確認できます。

pubspec.yaml

すると以下のようにコンソールに出力されます。

/Users/~/flutter/bin/flutter --no-color pub outdated
Showing outdated packages.
[*] indicates versions that are not the latest available.

Package Name                        Current      Upgradable  Resolvable  Latest  

direct dependencies:               
cloud_firestore                     *0.9.13+1  *0.9.13+1   1.0.0           1.0.0   
firebase_auth                       -                    *0.9.0          1.0.0           1.0.0   
firebase_core                       *0.3.0          *0.3.4          1.0.0           1.0.0   
fluttertoast                           -                    7.1.8           7.1.8            7.1.8  

他にも情報が出力されます。
それぞれの内容は以下のとおりです。

  • Current:現在のバージョン
  • Upgradable:アップグレードできる安定バージョン
  • Resolvable:現在使用している他のパッケージとの整合性を考慮して、アップグレードできるバージョン
  • Latest:β版も含めた最新版

なお、最新バージョンの指定には、前述のとおりバージョン番号未指定でできますが、同じく any と指定しても可能です。
その他、指定バージョン以上とか、指定バージョン未満など細かく指定することも可能です。
詳しくは参考URLより確認ください。

参考

https://dart.dev/tools/pub/versioning#semantic-versions

スポンサーリンク

Twitterでフォローしよう

おすすめの記事